Version: 1.1.5
Drivers: 4.2.8 and later
Win 98/Me/2000/Xp
For SkyStar2