I seem to have a problem I have dled the version 12.01.A5 for my digiquest 8000sci (kaon) box but when I try to install it i get fail. I have dled bm-8200ci_12.01.a5_071119 but that comes up wrong box.

i have tried Kaonteam BL219v4 and kup230 but it keeps coming up fail. I think I need 12.01.A5 570.

what file/firmware should I use?