fixed MINIMUM CLIENT VERSION check, broken since 2.1.0
several smartcard fixes